Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:

1524 (Excel)

.pdf
Скачиваний:
8
Добавлен:
09.04.2015
Размер:
362.76 Кб
Скачать

Министерство транспорта Российской Федерации Федеральное агентство железнодорожного транспорта

САМАРСКАЯ ГОСУДАРСТВЕННАЯ АКАДЕМИЯ ПУТЕЙ СООБЩЕНИЯ

Кафедра информатики

МЕТОДИЧЕСКИЕ УКАЗАНИЯ

k выполнению лабораторных работ с использованием MS EXCEL по дисциплине «ИНФОРМАТИКА»

для студентов технических специальностей дневной формы обучения

Составители: Юшков С. А. Ермоленко Т. И.

Самара 2005

УДК 681. 3. 01

Методические указания по выполнению лабораторных работ с использованием MS EXCEL по дисциплине «Информатика» для студентов технических специальностей дневной формы обучения. - Самара: СамГАПС, 2005.- 12 с.

Утверждено на заседании кафедры информатики 05.03.2005г., протокол 7.

Печатается по решению редакционно-издательскогосовета академии.

Данные методические указания содержат примеры выполнения лабораторных работ с описанием применения пакета МS Excel при решении инженерных, математических задач, в качестве простейшей однотабличной базы данных. Указания предназначены для студентов технических специальностей дневной формы обучения.

Составители:

Сергей Анатольевич Юшков

 

 

Татьяна Ивановна Ермоленко

 

Рецензенты:

Доцент кафедры АСОИиУ, к.т.н.

А. В. Авсиевич.

 

Профессор кафедры менеджмента и коммерции

 

Самарского филиала ВЭГУ, к.т.н.

Л. С. Попов.

Редактор: И. А. Шимина Компьютерная верстка: Чертыковцева Н. В.

Подписано в печать 08.06.05. Формат 60x90 1/16. Бумага писчая. Печать оперативная. Усл. п.л. 0,75. Тираж 300 экз. Заказ № 99.

© Самарская государственная академия путей сообщения, 2005

2

Введение

Одним из решающих факторов ускорения научно - технического прогресса на современном этапе является широкое использование средств вычислительной техники во всех областях человеческой деятельности. Современные условия эксплуатации железных дорог предъявляют высокие требования к специалистам, которые обязаны сочетать знания по своей специальности с навыками использования современных персональных компьютеров для решения разнообразных инженерных задач.

Основное назначение данных методических указаний - кратко, доступно, на конкретных примерах показать применение электронных таблиц MS Excel – заполнение рабочих листов, копирование информации, вычисление в таблицах, использование стандартных функций, подведение итогов, построение диаграмм и графиков.

Данные методические указания необходимы для первоначального изучения студентами технических специальностей принципов создания простых таблиц, приемов копирования и переноса информации, расчетов в таблицах, построения простейших диаграмм в пакете MS Excel.

Методические указания дают возможность студентам ознакомиться с порядком оформления отчета по лабораторным работам, а также освоить технологии решения прикладных задач по темам, соответствующим утвержденной программе лекционного курса.

Большое количество пояснительных комментариев, включенных в разделы, делает методические указания необходимыми при самостоятельном выполнении студентами лабораторных работ.

1.Требования к оформлению отчёта по лабораторной работе

Отчет должен содержать следующие пункты:

1.Условие задачи.

2.Описание и расположение рассчитываемых величин и комментариев в таблице.

3.Описание формул в ячейках таблицы.

4.Результаты расчетов (входные и выходные данные).

Начать выполнение лабораторной работы необходимо с постановки задачи. При постановке задачи нужно определить, какие данные и какие формулы будут вводиться в

соответствующие ячейки. Необходимо также указать, по каким формулам будет производиться расчет, и какие условия для этого должны выполняться.

2. Лабораторная работа №1. Табуляция функции

Порядок выполнения лабораторной работы рассмотрим на конкретном примере.

2.1.Условие задачи.

Найти и вывести на экран все значения функции

P 24.9

7

Sin

2K

на отрезке [A,B] с

 

 

2

 

 

шагом D. Подсчитать количество значений функции, больших 10.

2.2. Описание и расположение рассчитываемых величин и комментариев в таблице. Для выполнения задачи в программе MS Excel открываем рабочий лист 1 и заполняем его следующим образом:

Объединяем ячейки A1-С1и пишем текст «Табуляция функции».

В ячейке A4 набираем текст «начало отрезка».

В ячейке А5 набираем текст «конец отрезка».

В ячейке А6 набираем текст «шаг».

В ячейках В4, B5, В6 будут находиться значения начала отрезка, конца отрезка и шага

3

соответственно.

В ячейке А8 набираем текст «Проверка исходных данных».

В ячейке В8 будет находиться результат проверки исходных данных.

В ячейке A10 набираем текст «значение аргумента».

В ячейке В10 набираем текст «значение функции».

В ячейках A11-А20,B11-В20будут находиться значения аргумента и функции соответственно.

В ячейке D10 набираем текст «количество значений функции >=10».

В ячейке D20 будет находиться значение количества Р >=10.

Для этой задачи входными данными являются: начало отрезка, конец отрезка и шаг. Необходимо, чтобы значение начала отрезка было меньше значения конца отрезка, а шаг был больше нуля.

2.3.Описание формул в ячейках таблицы.

Вячейки В4 и В6 вводим значения начала отрезка, конца отрезка и шага соответственно. Для проверки входных данных в ячейку B8 запишем формулу

=ЕСЛИ(И(В4<В5;В6>0);”верно”;”повтор ввода”).

Первое значение аргумента должно равняться началу отрезка, поэтому в ячейку А11 записываем формулу =B4.

Вячейках А12-А20должны быть следующие значения аргумента (предыдущее значение плюс шаг). Если значение аргумента становится больше конца отрезка, то выводим сообщение «Конец отрезка». Для этого в ячейку А12 записываем формулу

=ЕСЛИ((А11+B$6)>B$5;”конец отрезка”;A11+B$6) и копируем ее вниз по столбцу до ячейки А20.

Вячейку В11вводим формулу для расчета значения функции =24,9*СТЕПЕНЬ(СТЕПЕНЬ(SIN(2*A10);2);1/7) и копируем ее вниз по столбцу до ячейки В20.

Для подсчета количества значений функции больших или равных 10ячейки D11D19 заполним единицами и нулями (единица, если удовлетворяет условию Р>=10, ноль - если нет). С этой целью в ячейку D10 запишем формулу

=ЕСЛИ(В11>=10;1;0) и копируем ее вниз по столбцу до ячейки D19.

Вячейку D20 запишем формулу

=СУММ(D11:D19), где и получим искомый результат.

2.4.Результаты расчетов (входные и выходные данные).

3.Лабораторная работа №2. Построение графика функции

Порядок выполнения лабораторной работы рассмотрим на конкретном примере.

3.1.Условие задачи.

Нарисовать график функции Y=AB|sin(AB)|.

3.2.Описание и расположение рассчитываемых величин и комментариев в таблице. Для выполнения задачи в программе MS Excel открываем рабочий лист 1 и запол-

няем его следующим образом:

Объединяем ячейки A1-G1и пишем текст задания.

В ячейке A4 набираем текст «начало отрезка».

В ячейке А5 набираем текст «конец отрезка».

В ячейке А6 набираем текст «шаг».

В ячейках A5, B5, C5 будут находиться значения начала отрезка, конца отрезка и шага

соответственно.

4

В ячейке A8-A9набираем текст «значение аргумента».

В ячейке В8-B9набираем текст «значение функции».

В ячейках A10-А21,B10-В21будут находиться значения аргумента и функции соответственно.

Для решения задачи необходимо выполнить следующие условия:

1.Начало отрезка должно быть меньше конца отрезка.

2.Начальное значение аргумента должно равняться началу отрезка.

3.Конечное значение аргумента должно равняться концу отрезка.

4.Количество шагов примем равным 10.

3.3.Описание формул в ячейках таблицы.

Вячейки А5 и В5 вводим значения начала и конца отрезка соответственно. В ячейку С5 записываем формулу для расчета шага

=(B5-A5)/10.

Вячейку А10 нужно записать начальное значение аргумента и проверить условие – начало отрезка должно быть меньше конца отрезка, поэтому записываем в ячейку А10 следующую формулу

=ЕСЛИ(A5<B5;A5;”повтор ввода”).

Вячейку А11 нужно записать следующее значение аргумента и определить конец отрезка. Для этого в ячейку А11 запишем формулу =ЕСЛИ(А10>=B$5;”конец отрез-

ка”;A10+C$5)

и копируем ее вниз по столбцу до ячейки А21.

Вячейку В10 запишем формулу для расчета значений функции Р

=A10*АВS(SIN(A10))

и скопируем ее вниз по столбцу до ячейки В21.

Для построения графика выделяем значения аргумента и функции (А10-А20,В10В20), затем на панели инструментов выбираем пиктограмму «Мастер диаграмм», выбираем тип диаграммы (точечная), ее вид и нажимаем кнопку «Готово». Полученную диаграмму размещаем на рабочем листе.

3.4.Результаты расчетов (входные и выходные данные).

5

4. Лабораторная работа №3. Одномерный массив

Порядок выполнения лабораторной работы рассмотрим на конкретном примере.

4.1.Условие задачи.

Дано 10 оценок, найти среднее арифметическое всех оценок. Ввод оценок произвести с клавиатуры.

4.2. Описание и расположение рассчитываемых величин и комментариев в таблице. Для выполнения задачи в программе MS Excel открываем лист 1 и заполняем его следующим образом:

Объединяем ячейки A1-С1и пишем текст задания.

В ячейке A4-А5набираем текст «№ оценки».

В ячейке В4-В5набираем текст «Введи оценку».

В ячейке С4 набираем текст «Проверка ввода».

В ячейке Е4 набираем текст «Средняя оценка =».

4.3.Описание формул в ячейках таблицы.

В ячейку А6 заносим число 1. В ячейку А7 вводим формулу = А6+1 и копируем ее вниз по столбцу до ячейки А15.

Вячейки В6-В15вводим значения оценок соответственно.

Вячейку С6 записываем формулу для проверки правильности ввода оценок (они не должны быть больше 5 и меньше 1)

=ЕСЛИ(И(B6<=5; B6>=1);”верно”;”повтор ввода”)

икопируем ее вниз по столбцу до ячейки С15.

Вячейку F4 запишем формулу для определения средней оценки

=СУММ(B6:B15)/10.

4.3.Результаты расчетов (входные и выходные данные).

6

5.Лабораторная работа №4. Двумерный массив

Порядок выполнения лабораторной работы рассмотрим на конкретном примере.

5.1.Условие задачи.

Дана матрица 15x15. Элементы матрицы рассчитываются по формуле Elem=N+M, где N - номер строки, М - номер столбца. Найти максимальный элемент в каждой строке и минимальный элемент в каждом столбце.

5.2Описание и расположение рассчитываемых величин и комментариев в таблице. Для выполнения задачи в программе MS Excel открываем рабочий лист1 и запол-

няем его следующим образом:

В ячейках А3-А16будут находиться порядковые номера строк.

В ячейках В2-Р2будут находиться порядковые номера столбцов.

В ячейках В3-Р16будут находиться значения элементов матрицы.

В ячейку А18 записываем текст «max».

В ячейках В18-Р18будут находиться максимальные значения каждого столбца матрицы.

В ячейку R2 записываем текст «min».

В ячейках R3-R16будут находиться минимальные значения каждой строки матрицы.

5.3.Описание формул в ячейках таблицы.

Вячейку А3 заносим число 1. В ячейку А4 вводим формулу = А3+1 и копируем ее вниз по столбцу до ячейки А16.

Вячейку В2 заносим число 1. В ячейку С2 вводим формулу = В2+1 и копируем ее вправо по строке до ячейки Р2.

Для расчета элементов матрицы в ячейку В3 запишем формулу =$A3+B$2 и скопируем ее вправо по строке до ячейки Р3.

Затем выделяем ячейку В3 и копируем ее вниз по столбцу до ячейки В16. Аналогичным образом копируем ячейки С3-Р16.

7

Для определения минимального элемента в каждой строке матрицы, в ячейку R3 запишем формулу

=МИН(В3:Р3) и скопируем ее вниз по столбцу до ячейки R16.

Для определения максимального элемента в каждом столбце матрицы, в ячейку В18 запишем формулу

=МАКС(В3:В16) и скопируем ее вправо по строке до ячейки Р18.

5.4Результаты расчетов (входные и выходные данные).

6.Лабораторная работа №5. Строковые величины

Порядок выполнения лабораторной работы рассмотрим на конкретном примере.

6.1.Условие задачи.

Составить программу определения места расположения символа «е» при многократном вхождении в строковую величину «элемент».

6.2.Описание и расположение рассчитываемых величин и комментариев в таблице.

Для выполнения задачи в программе MS Excel открываем рабочий лист 1 и заполняем его следующим образом:

-Объединяем ячейки A1-В1и пишем заглавие задания.

-В ячейке A4 набираем текст «слово».

-В ячейке А5 набираем текст «кол-восимволов».

-В ячейке А7 набираем текст «номер символа».

-В ячейке В7 набираем текст «номер позиции символа «е».

6.3.Описание формул в ячейках таблицы.

Вячейку В4 вводим слово «элемент». Для определения количества символов в слове в ячейку В5 записываем формулу

=ДЛСТР(В4).

Для определения № символа в ячейку А8 записываем 1. В ячейки А9-А15мы должны занести номера символов, равных предыдущему значению плюс 1. Если значение в ячейке становится больше количества символов, тогда в ячейке должно появиться сообщение «конец слова». Для этого в ячейку А9 запишем формулу

8

=ЕСЛИ(А8>=B$5;”конец слова”;A8+1) и копируем ее вниз по столбцу до ячейки А15. Чтобы определить наличие и номер символа «е» в слове «элемент», в ячейку В8 запишем следующую формулу

=ЕСЛИ(СОВПАД(ПСТР(В$4;A8;1);”e”);A8;” “) и скопируем ее вниз по столбцу до ячейки В14.

6.4.Результаты расчетов (входные и выходные данные).

7. Функции

Для выполнения вычислений на листах книги можно использовать стандартные функции Microsoft Excel.

Величины, которые используются для вычисления значений функции, называются аргументами.

Величины, которые являются результатом вычисления функции, называются возвращаемыми значениями.

Последовательность, в которой должны располагаться аргументы функции, называется синтаксисом функции.

Чтобы использовать функцию, её нужно ввести как часть формулы в ячейку листа. Если функция стоит в самом начале формулы, ей должен предшествовать знак равенства, как и всякой другой формуле. Для обозначения начала и конца списка аргументов используются парные скобки, пробелы перед скобками и после них не допускаются. Внутри скобок располагается список аргументов, который может состоять из чисел, текста, логических величин, массивов, значений ошибок или ссылок. Аргументы могут быть как константами, так и формулами. Эти формулы, в свою очередь, могут содержать другие функции. Функции, являющиеся аргументом другой функции, называются вложенными. В формулах возможно использование до семи уровней вложения.

8. Список основных стандартных функций Microsoft Excel

=ЕСЛИ(лог выражение; значение если истина; значение если ложь) -функция ЕСЛИ – вычисляет одно значение, если заданное условие при вычислении даёт значение ИСТИНА, и другое значение, если ЛОЖЬ.

9

Лог выражение - это любое значение или выражение, которое при вычислении дает значение ИСТИНА или ЛОЖЬ.Лог выражение может быть другой формулой.

Значение если истина - это значение, которое вычисляется, еслилог выражение имеет значение ИСТИНА.Значение_если_истина может быть другой формулой.

Значение если ложь - это значение, которое вычисляется, еслилог выражение имеет значение ЛОЖЬ.Значение если ложь может быть другой формулой.

=СТЕПЕНЬ(число;степень) - функция СТЕПЕНЬ – вычисляет результат возведения в степень.

Число - это основание. Оно может быть любым вещественным числом.Степень - это показатель степени, в которую возводится основание.

=СУММ(число1;число2; ...) - функция СУММ – выполняет суммирование значений, указываемых её аргументами.

Число 1, число 2, ... - это от 1 до 30 аргументов, для которых требуется определить итог или сумму. Аргументы, которые являются значениями ошибки или текстами, не преобразуемыми в числа, вызывают ошибки.

=ABS(число) - вычисляет модуль (абсолютную величину) числа, гдечисло - это действительное число, абсолютную величину которого требуется найти.

=SIN(число) - функция SIN – вычисляет синус данного угла.Число - это угол в радианах, для которого вычисляется синус.

=МИН (число 1; число 2; ...) - функция МИН – вычисляет минимальное значение из списка аргументовЧисло 1, число 2, ... - это от 1 до 30 чисел, среди которых ищется минимальное значение.

=МАКС (число1;число2; ...) - функция МАКС – вычисляет максимальное значение из списка аргументовЧисло 1, число 2, ... - это от 1 до 30 чисел, среди которых ищется максимальное значение.

=ДЛСТР (текст) - функция ДЛСТР – вычисляет количество знаков в текстовой строке, длину которой надо определить.

Текст - это текст, длина которого определяется. Пробелы считаются как символы.

=СОВПАД (текст 1; текст 2) - функция СОВПАД – сравнивает две строки текста и вычисляет значение ИСТИНА, если они в точности совпадают, и ЛОЖЬ в противном случае.

Текст 1 - это первая текстовая строка.Текст 2 - это вторая текстовая строка.

=ПСТР (текст; начальная позиция; количество символов) - функция ПСТР – возвращает указанное число знаков из текстовой строки, начиная с указанной позиции.

Текст - это текстовая строка, содержащая извлекаемые символы.

Начальная позиция - это позиция первого символа, извлекаемого из текста. Первый символ в тексте имеет начальную позицию 1 и так далее.

Количество символов указывает, сколько символов нужно вернуть.

10

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]

Калькулятор

Сервис бесплатной оценки стоимости работы

  1. Заполните заявку. Специалисты рассчитают стоимость вашей работы
  2. Расчет стоимости придет на почту и по СМС

Нажимая на кнопку, вы соглашаетесь с политикой конфиденциальности и на обработку персональных данных.

Номер вашей заявки

Прямо сейчас на почту придет автоматическое письмо-подтверждение с информацией о заявке.

Оформить еще одну заявку